The Most Dog Friendly Community Online
Join and Discover the Best Things to do with your Dog

Welcome to Our Community
Wanting to join the rest of our members? Feel free to sign up today.

Dog Grooming - Help

Discussion in 'Dog Grooming' started by jji, Feb 16, 2013.

  1. jji

    jji New Member Registered

    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    0
    I have just used my new Wahl clippers plus blade attachment for the first time and had a bit of a disaster. The first side lots of hair came off but when I took the attachment off to clean it and put it back on, things didn't seem to work. I don't think the clippers are cutting the hair but I've checked everything and can't see where the problem is.

    I have tried just using the blade on it's own but even then it won't cut short enough. I have an 8.5 Competition Series blade which came with the clippers. After I used it the first time, it felt like the blade was dragging through the hair but I have checked and the blades are moving.

    I have just moved to Glasgow for 18months and don't know anyone or where to go to get some help - I can find someone on Monday no doubt.

    Can anyone give me any advice meanwhile please?
     
  2. banana

    banana New Member Registered

    Messages:
    1,322
    Likes Received:
    58
    Trophy Points:
    0
    You need to make sure there is no hair stuck in them and you normally get oil with them and need to keep them oiled I think?

    Welcome to Dog Forum, I am Anna :)
     
  3. Shamrock

    Shamrock New Member Registered

    Messages:
    104
    Likes Received:
    6
    Trophy Points:
    0
    The comb attachments work a lot better on a 30 or 15 blade, I've never tried to use them with a 8.5 . It sounds as though the blade is clogged up, try sliding the upper blade over a bit, and brush, then to the other side, oil, and try again.
     
  4. jji

    jji New Member Registered

    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    0
    Thank you both for your advice. I have reoiled and yes, I think it has something to do with the blade size, think I need to order another size.

    I am Jennie, I will get around to getting a photo of my lovely patient wheaten terrier!
     
    Shamrock likes this.
  5. Dizzyjenni

    Dizzyjenni New Member Registered

    Messages:
    466
    Likes Received:
    9
    Trophy Points:
    0
    Hi! Welcome to the forum :) Hope you sort the clippers out soon.
     
  6. lurcherman

    lurcherman Well-Known Member Registered

    Messages:
    1,378
    Likes Received:
    247
    Trophy Points:
    63
    welcome to the wonderful world of k9 :thumbsup:
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.